Apresentação
Intro-hlp3.jpg (13844 bytes)
Você necessita de uma ferramenta de comunicação simples, fácil e rápida? Que tal o InterCom?

InterCom é um sistema utilitário distribuído de maneira livre (FREEWARE). Seu objetivo é a comunicação interna na sua empresa ou casa de maneira simples e rápida.

Esperamos que o sistema corresponda as suas expectativas. Estaremos sempre receptivos a novas sugestões sobre este e outros produtos, bem como a novas idéias para o desenvolvimento de pequenos produtos de grande utilidade e simplicidade. Para entrar em contato conosco, visite nosso site www.athenas.com.br, conheça mais sobre a empresa e deixe o seu recado!


Projeto Freeware

Nossa empresa desenvolve softwares personalizados, e em paralelo a isso criamos o Projeto Freeware que destina-se a produzir pequenos utilitários (como a MiniAgenda, DigitCheck e o MiniBiblio que já saíram em diversas revistas da área como InfoExame, CD Expert, CD Fácil, etc) de uso geral para divulgação da empresa.

software_minibiblio.jpg (4012 bytes)

O desenvolvimento de sistemas freeware faz parte de uma ideologia, que estabelece uma interação entre usuários e desenvolvedores, a medida que os usuários/colaboradores fornecem suas sugestões para o aprimoramento destes softwares, estes tornanam-se cada vez mais interessantes. Visite nosso site www.athenas.com.br e conheça outros softwares do projeto freeware, a sessão "Diversão" com downloads de jogos, wallpapers e screensavers além de descobrir mais sobre a Athenas Softwares & Systems.

O InterCom surge como mais uma etapa desse processo. Também é um pequeno utilitário porém possui enorme funcionalidade.


Primeiro Logon

O Comunicador possibilita, sempre que for executado, abrir o canal de comunicação de forma automática para que o usuário já possa desfrutar dos recursos de comunicação. Se o usuário não quiser usufruir desse recurso o sistema exibirá uma tela onde deverão ser informados o nome do usuário que deseja entrar e o canal de comunicação que será utilizado.

primeiro_logon.jpg (11253 bytes)


Árvore de Usuários

Os usuários do InterCom que estiverem operando no mesmo canal aparecerão em uma árvore na janela do comunicador, e a partir desta árvore o usuário poderá se comunicar com os demais e ver em que estado eles se encontram.

arvore_usuarios_ORIG.jpg (16602 bytes)

Assim como os demais comunicadores, um usuário pode escolher um estado de acordo com a sua situação no momento. Caso não possa atender nenhuma mensagem pode escolher "ocupado"; caso não esteja presente pode escolher "ausente" e por ai vai. No InterCom ele poderá escolher entre qualquer um dos estados indicados:

estados_ORIG.jpg (5029 bytes)

O estado do usuário pode ser definido através do menu popup que aparece quando se clica no ícone do comunicador na barra de tarefas ou quando se clica na imagem do usuário na janela principal do comunicador.

troca_estado_ORIG.jpg (17524 bytes)

O InterCom pode ser configurado para entrar em modo "ausente" de forma automática se o protetor de tela do computador for acionado. Veja como configurar esse importante recurso em Configurações.


Envio de Mensagens

Para enviar uma mensagem basta selecionar o usuário ou o grupo de usuários a quem a mensagem se destina e clicar com o botão da direita para aparecer um menu popup. A janela de envio possui a área de digitação e a área de destinatários. Os usuários que estiverem marcados receberão a mensagem. Para enviar a mensagem basta acessar o menu da janela ou clicar no botão "Enviar para".

envio_msg.jpg (15161 bytes)

Cada mensagem pode receber uma face indicando o "estado de humor" de quem envia a mensagem naquele momento. Para alterá-la basta clicar sobre a imagem pré-definida que aparecerão os outros "estados de humor". Nesta versão existe um limite de 300 caracteres para o envio da mensagem.

troca_humor.jpg (22053 bytes)

Caso o usuário deseje, o InterCom pode ser configurado para emitir algum som ao enviar uma mensagem, por exemplo. Esse e outros recursos podem ser vistos em Configurações.


Recebimento de Mensagens

Ao chegar uma mensagem o InterCom exibe a janela de histórico de mensagens com a última mensagem recebida. E isso ocorre de forma sem perturbar o que o usuário estiver fazendo no momento. A janela de históricos exibe as mensagens recebidas e enviadas pelo usuário logado no sistema no momento, sendo que o usuário pode escolher visualizar apenas as enviadas, as recebidas ou ambas.

hist_msg.jpg (20180 bytes)

Caso o usuário queira poderá limitar a quantidade de mensagens exibidas no histórico, assim como a quantidade armazenada nos arquivos de histórico. Para isto basta ir em Configurações. Caso o usuário prefira, existe a possibilidade da janela de histórico não aparecer quando chega uma mensagem. Nesse caso, o InterCom pode ser configurado para exibir um aviso na barra de tarefas até que a janela de histórico seja ativada. Assim como no envio, caso o usuário queira o InterCom pode ser configurado para emitir algum som ao receber uma mensagem. Esse e outros recursos podem ser vistos em Configurações.


Backup - Como Funciona

Como Funciona?

É recomendado que periodicamente seja feito um backup dos dados cadastrados no InterCom, assim você estará realizando uma cópia de segurança de seus dados. Caso ocorra algum problema em seu computador, ou você instale uma nova versão do InterCom, seus dados poderão ser restaurados e nada do que foi armazenado será perdido.

Para fazer um backup do banco de dados atual clique no menu "Opções" na janela principal e selecione a opção "Backup". Assim, o comunicador perguntará qual o nome que você prefere para o Backup. Será sugerido junto à pergunta um nome, contendo a data e a hora em que foi feito o Backup. Mude se assim preferir. A cópia de segurança será salva no mesmo diretório em que está instalado o InterCom, originalmente C:\Arquivo de Programas\InterCom.

Para utilizar (restaurar) o Backup feito, clica-se no menu "Opções" e seleciona-se "Restore". O comunicador abrirá uma janela que mostrará os Backups já realizados. Você poderá então escolher aqueles que quiser incorporar ao banco de dados atual.

Esperamos que o sistema corresponda as suas expectativas. Estaremos sempre receptivos a novas sugestões sobre este e outros produtos, bem como a novas idéias para o desenvolvimento de pequenos produtos de grande utilidade e simplicidade. Para entrar em contato conosco, visite nosso site www.athenas.com.br, conheça mais sobre a empresa e deixe o seu recado!


Configurações

Aqui será possível configurar as ações que o InterCom deve efetuar ao enviar uma mensagem, se deve iniciar o canal de comunicação logo quando é executado e etc.

configuracoes.jpg (29076 bytes)

As configurações dividem-se em "principal" e "gerais".

- Na primeira configura-se o canal de comunicação e em quais situações a janela principal será exibida. Pode-se configurar também que ações o InterCom deve efetuar quando recebe e quando envia uma mensagem.

- Na segunda guia pode-se configurar o sistema para que abra o canal de comunicação logo que for executado, com um usuário e um estado pré-definidos. Finalmente, pequenas otimizações disponíveis relacionadas à exibição e ao armazenamento das mensagens.


Sobre a Athenas - Empresa

A Athenas Software & Systems atua nas áreas de desenvolvimento e suporte em informática. A empresa vem se consolidando no mercado há 5 anos, nasceu de um projeto da Pontifícia Universidade Católica que envolvia seus atuais sócios. Com a dedicação total, e seu potencial voltado para o cliente, capacitou-se para atender empresas de médio e grande porte que hoje formam o seu maior patrimônio, a confiança.

Atualmente conta com uma equipe altamente especializada e com instrumentos adequados a cada situação.

O seu investimento abrange desde a aquisição de ferramentas mais modernas até o aprendizado de novas tecnologias. Com o crescimento em grande escala da Web e com o aumento da procura de serviços nesse setor, a Athenas surge oferecendo soluções indispensáveis para essa nova fase de negócios na internet. Mostrando a mesma excelência dos demais serviços, é criada uma divisão voltada exclusivamente para e-business e webdesign. A união do domínio tecnológico e do design criativo, comprovam a excelência dos trabalhos aqui realizados.


Sobre a Athenas - Atuação

A Athenas Software and Systems realiza, desde 1996, análise, planejamento e execução de projetos e sistemas informatizados. A plataforma de trabalho é baseada no ambiente Microsoft Windows utilizando Borland Delphi e Borland Interbase como ferramentas de desenvolvimento de aplicações e gerenciador de banco de dados.

O conhecimento e tecnologia adquiridos neste período nos permite atuar em diferentes áreas do mercado passando por distribuição, produção, ensino a distância e comércio entre outras oferecendo sistemas que permitem aos nossos clientes controle, segurança e agilidade no tratamento das informações.


Dúvidas Gerais

n O que é backup?
Em inglês, o termo "backup" se refere a peças de reposição ou de reserva. Em informática, o termo foi adaptado para designar as cópias de segurança feita de arquivos ou sistemas completos, para serem utilizadas em caso de panes ou simplesmente para transferir dados de um computador a outro. Apesar do termo poder ser traduzido para o português como "reserva" ou "cópia de segurança", o termo acabou sendo incorporado 'a linguagem do dia a dia seguindo o caminho de outros termos como, por exemplo "Formatar", herdado do termo inglês "Format". Assim, não é de se estranhar que se ouça alguém falando em "becapear os dados", significando que vai fazer uma cópia de segurança dos mesmos..

n O que é Plug-In?
São módulos de programa adicionais que podem ser instalados (acoplados) ao programa original a critério do usuário. Plug-ins permitem aumentar a funcionalidade do programa conforme as necessidades do usuário. Cada fabricante de software tem suas normas para criação de Plug-Ins e os Plug-ins compatíveis com o InterCom são distribuídos através de nosso site (www.athenas.com.br). A instalação de Plug-Ins não oficiais fica sobre a responsabilidade do usuário e a Athenas não se responsabiliza por danos causados por Plug-ins desta natureza.

n Como instalar um Plug-In?
Os Plug-ins para o InterCom serão disponibilizados com um instalador que efetuará automaticamente o "acoplamento" ao seu InterCom, note que é importante informar para o instalador do Plug-In onde seu InterCom está instalado.

n Qual o significado do número de versão do sistema?
O número de versão do sistema segue o padrão indicado pela Borland:"Version","Minor Version","Release","Build".
Version: Versão do sistema em si, determina o número da versão atual do sistema, este número sendo diferente entre versões indica uma grande mudança estrutural e lógica entre os mesmos.
Minor Version: Indica pequenas alterações sobre uma versão, adição ou retirada de novas funcionalidades. Ou um conjunto de dez releases.
Release: Indica alterações relativas a correções de Bugs sobre uma "Minor Version", pode também indicar modificações internas (sem efeito aparente ao usuário final). A cada dez adiciona-se uma Minor Version e zeramos o release.
Build: Número de vezes que o programa fora compilado desde sua criação. Controle para os desenvolvedores.